Google Earth Pro and other Google Mapping Products
Google Earth doesn’t show the recent natural calamities on Highway 1.
Pfeiffer Canyon Bridge Big Sur CA Partial collapse on 2/25/17
Mud Creek Landslide   05/120/17 and Mud Creek 2
http://www.sfchronicle.com/bayarea/article/Bridge-failure-severs-Big-Sur-s-ties-to-outside-10958200.php

Access Google Maps from https://www.maps.google.com  (redirects to www.google.com/maps) 
Good GM tutorial at https://www.youtube.com/watch?v=XQUaQpoF8xE 
Download Google Earth from https://www.google.com/earth/
Download Google Earth Pro from https://www.google.com/earth/download/gep/agree.html
Good GEP tutorial at https://uwaterloo.ca/library/geospatial/sites/ca.library.geospatial/files/uploads/files/google_earth_2016.pdf
In order to use GEP, users will need to enter their email address and the key GEPFREE.
GM is optimized to be used for getting directions while driving.  It can show routes, local businesses and photos.
GE and GEP are better suited for viewing information geographically; showing climate information, analyzing change over time, viewing historical imagery, importing shape files, geocode addresses, and creating routes.
Screen Shots
Google Maps – Map view
Google Maps -Satellite view
Google Earth
Google Earth Pro   
Both GE and GEP have a button to switch to Google Maps
[image: C:\Users\ralph\AppData\Local\Temp\SNAGHTMLfd54a26.PNG]
Feature Comparison of GE and GEP
	Features
	Google Earth
	Google Earth Pro

	Print resolution
	1000 pixels
	4800 pixels

	Import GIS data
	---
	ESRI .shp, MapInfo .tab

	Import addresses in bulk
	Manually Geo-locate each address
	Automatically Geo-locate up to 2500 at a time

	Import large image files
	limited to texture size
	Super Image Overlays

	Supplemental Layers
	---
	Demographics, Parcels, Traffic Counts

	Create premium movies for export
	---
	HD 1920x1080

	Measurement tools
	Line, Path
	Line, Path, Polygon, Circle, 3D Path, 3D Polygon




What's the difference between Google Earth and Google Earth Pro?
From http://download.cnet.com/guides/google-earth/  
Google Earth lets you explore extensive geographical content, zoom from space to street level, search businesses, visualize and share your GPS tracks, fly around the world in 3D, time travel with historical imagery, and dive beneath the surface of the ocean.
Google Earth Pro enables you to utilize everything Google Earth has to offer, plus capitalize on advanced business tools, which enable you to compute distances and areas using measurement tools, use Movie Maker to create media collateral, print high-res images for reports, import large vector image files to quickly map GIS data, and map addresses with the Spreadsheet Importer.
By default, GM does not provide a high-resolution image for using in documents
This link shows how to get a higher resolution image in that program
http://www.alvipixels.co.uk/blog/high_resolution_google_map_300dpi.php 
Observations
GEP and GE share the same myplaces.klm file, where all of a user’s personally created files are stored.  In order to preserve files from one session to another, save them to My Places.  (Save/Save My Places).
Recent Product Changes:
The following three layers and Parcel (APN) Search feature were removed from Google Earth Pro on January 29, 2016:
U.S. Demographics, U.S. Parcels Data, U.S. Daily Traffic Counts
Live traffic is still available in Google Maps (https://www.google.com/maps/ ).  You can access it via the option in the left menu.  Click the three horizontal lines at the top left to access the menu.
File Types
.kml;  Keyhole markup language 
About KML files;  https://developers.google.com/kml/ 
KMZ; zipped kml files
GEP is available for Windows, Mac and Linux
Explanation of how to install GEP on Ubuntu from the Terminal
http://ubuntuhandbook.org/index.php/2017/04/install-google-earth-in-ubuntu-17-04/
Show the power of opening a .kml file in GEP
https://developers.google.com/kml/media/everytrail_halfdome.kmz 
Display Sutter Demo folder in GEP for Half Dome, Earthquakes and London
[image: ]Using GEP; Lopez Lake
Add Placemarks
Use the Add Path Tool to draw a route
Set the viewing altitude (Right-click Path/Properties/Altitude)
Set the playback speed
Record a tour by tracing a route and then clicking the tour button 
Play screen capture of tour
Play the Tour
Demo the Historical Slider to show changing water levels
Check/uncheck boxes to display or hide the route
Show Elevation Profile (Right-click/Path/Profile)

To share data between multiple instances of GEP 
Import previous sessions by opening myplaces.kml with GEP
On my Windows machine running Windows Creator’s Edition, 
the file resides at
C:\Users\ralph\AppData\LocalLow\Google\GoogleEarth\myplaces.kml
E-mail the file to another user.  Instruct user to open the file with GEP 
(File/Open)  He or she can then save the files to My Places in GEP
Narrated tour of Lopez Lake from the Lopez Lake Marina to Lopez Arm Camp
http://www.slobytes.org/presentations/sutter-0617/lopez-lake-tour.mp4
Detailed Recording Steps with Movie Maker
[image: ]Make sure that all files that are part of the same tour are saved in the same folder

[image: ]Right click on a path to show the options here


Set height of camera above the terrain here
Select Path

[image: ]








[image: ]Set video frame speed from this box on accessed
By clicking Tools/Options 






[image: ]
Play a Tour by clicking this icon 








Uncheck the Path that you are highlighting if you do not want
it to display in the recorded Tour.  (The Tour will still follow the
route marked by the Path.
[image: ]
Access GEP Movie Maker here   
Audio doesn’t work.  Use Audacity
To record the audio track while playing the 
Video by running the .kml/kmz file.
Put audio and video together with Adobe
Premiere Elements or similar video editor

[image: ]Set the Movie Maker Resolution here.



If Movie Maker is greyed out, make sure that                 [image: ]
Record a Tour is not enabled (controls appear
on bottom of screen) 

[image: ]Draw Paths in GEP with this tool
Note:  Do not click OK until you are done
drawing the path.  Otherwise you will close
the dialog box 






Set Snagit video capture resolution here  (video screen capture)
You may wish to play the Tour with GEP while doing a video screen capture with Snagit, set for high resolution.
Otherwise, you can record the Tour with GEP’s Movie Maker and add audio upon playback
[bookmark: _GoBack]Topo Fusion is a GPS mapping program that allows you to create overlays of map content to GEP or similar programs
I have posted a video screen capture of the program here.



Resources
Creating a Tour Istanbul to Barcelona - https://www.youtube.com/watch?v=mxzkM6pUL-4&t=505s  
https://www.youtube.com/watch?v=EYHhhMlFdsY GEP Tutorial
Movie making with Google Earth Pro
The following is from 
https://docs.google.com/document/d/14WEgTl1-_7unaQQqJPDjd18Fp6aiK9XLMaAhvwZ0mQU/edit# 
In this document
Minimum suggested hardware specs 
Recommended tour creation workflow
Troubleshooting guide
Recording tours with info windows
Recording videos for YouTube
Movie making with Google Earth: Recommended hardware specs 
The following specs are suggested minimums when using Google Earth Pro to export movie files (aka Movie Maker). More RAM and a fast graphics processor card will allow for faster exports with less artifacts. It’s always recommended that Google Earth Pro be the only program running while exporting movie files. To learn more about using our maps on TV or in film, visit the Google Permissions website.
PC:
Intel Xeon 5150 @ 2.66GHz 2.67GHz (2 processors)
RAM: 8 GB
64-Bit OS, Windows 7
NVIDIA Quadro FX 5600 (March 2007 - PCI Express - NVIDIA - 1.5 GB - PNY - DVI - Dual-link DVI - 3840 x 2400)
Mac:
Processor 1.7 GHz Intel Core i5
RAM: 8 GB
OSX 10.8.2
Attached monitors should be at least as high a resolution as your target video export resolution size (e.g. 1080p).
Movie making with Google Earth: Recommended tour creation workflow
Following these recommended steps for creating an animation in Google Earth should save you some rendering troubles down the road. When recording your tours, there are a few options:
Record a Tour tool 
This tool is located in the top menu bar and looks like a small video recorder. When you are recording a tour like this, the program takes data points during your screen movements. This results in a large file, as it captures hundreds of data points every second. When you record a movie from a tour like this, it often will have wobbles or jumps. 
Play Tour tool
This will create a tour based on a folder of Placemarks, resulting in a much smaller tour file that won't develop a wobble when recording a movie. We have a site set up with the instructions for this here:
https://sites.google.com/site/kmltouring/google-earth-tools/record-a-tour 
Go to Recording from Placemarks. There is a video, as well as instructions on how to use this method.
Movie making with Google Earth: Troubleshooting guide
We often get questions from users having trouble rendering out their movies from Google Earth Pro. Google Earth’s a very powerful program that serves a ton of data. Sometimes buildings can be slow to load in your tour, or you’ll notice a little jarring movement in some of your flytos. We thought making a cheat sheet of rendering tips would be helpful. If you have tips of your own, please share them with us at mediatools@google.com — we’d love to hear them!
What’s the first thing I should know about rendering with Movie Maker?
Rendering works fine on both PCs and Macs, but ideally, you’re working with a combination of powerful video card — here’s one we know works well: NVIDIA Quadro FX 5600 — and lots of RAM (8 GB or more). 
What can I do to fix the issues I’m seeing?
It’s best practice to clear your cache before running a tour that has a lot of 3D buildings, terrain data, or camera angles that show a wide swath of land at the same time. To clear your cache: 
First, be sure to save your tour. 
Go to “Google Earth Pro” in the menu, and select Preferences
Under Preferences, select the Cache tab
Select both Clear memory cache and Clear disk cache
Quit Google Earth Pro, then relaunch it 
Play through your tour a few times to prime the cache with the imagery in your tour
Render and export your movie file
If clearing my cache doesn’t work?
Don't record anything — just play through the tour, stopping and starting every few seconds after you see the buildings along the route load. This gives the program time to load all the data. When it's at a tilted view, it's trying to load all the building data in the far back, and — as we mentioned before — because it's a ton of data, it takes a bit to load. Once you've gone through the tour, try recording again and see how it looks.
What other tips can I try?
Quit all other programs you might have running.
Using a MAC? Go to Tools > Options > 3D View tab. You'll see a section called Graphics Mode, with OpenGL and Direct X listed. Try selecting the other one and see if that helps.
Install another version of Google Earth Pro. In regards to movie making, sometimes an older Earth build is more stable than a new one. Download past releases here. Don’t know which version you’re using? Go to the menu and select About Google Earth Pro.
Make sure no other windows (e.g. e-mail) are covering the recording window.
Go to Preferences > Cache and try:boosting Memory cache (1024MB is the max), Disk Cache 2000.
Kill all layers except for Terrain and 3D buildings, as required.
Go to Preference> Touring and select Higher Fidelity When Recording A Tour at the bottom. Note: The basically increases the sample-rate when creating a Tour. Cranking it all the way up will sometimes make a huge file, and might even introduce strange flight path interpolation wobbles/artifacts. We generally recommend keeping this somewhere between 1/3 and 2/3 of max.
Go to Preferences> 3D View and check the Use High Quality Terrain option, or disable for faster rendering 
if you’re on a Windows Machine, try turning off override for anti-aliasing
Turn off Compass: View > Show Navigation > Never
If you’re on a Windows machine, you may be able To tweak the codec options, by droping a .prx file next to googleearth.exe.  You can find out more information about creating .prx files here, and here.
Set your video adapter refresh rate to an integer multiple of the video's fps. Don't try to record 60fps on a 75Hz display.
On Windows, if you have sufficient hard drive space, you will often get better quality results by recording the movie as an uncompressed AVI file (under the “Advanced” checkbox) and then re-encoding the movie yourself with something like QuickTime Pro for Windows or another program to a codec like H.264. Some of the default WMV codec options don’t yield very high quality output.
Movie making with Google Earth: Recording tours with info windows
Google Earth lets you record animations with terrain, Movie Maker lets you capture more than just terrain... you can capture KML layers, lines, points, polygons, ground overlays, screen overlays, etc.  but Movie Maker does not capture any info windows (aka popup balloons) you may have added to your map. In order to see these balloons pop up in your tour, you’ll need to use screen capturing software (e.g. Camtasia). You’ll be able to capture your tour, edit it, add a soundtrack, and add text overlays. Just fly through Google Earth while it's recording. Note that you'll need a fast computer to do it. 
You’ll want your Preferences to be set to: 
Set your Time Between Features to 0.18,  Check on Show balloon when tour is paused.
Highlight tour, then hit play, and it will go through and pop the balloons.
Resize window of Google Earth to a standard size. Under view menu, use View Size, and choose 800x600 if using big balloons with content.
Turn off Compass: View > Show Navigation > Never
Fly a path that you will take at a slow speed to allow Google Earth to load in all of the imagery to the cache.
Delete assets from your My Places menu.
Go to Preferences > 3D View > Make Labels/Icon size Large 
Before starting your Camtasia Capture:
Shoot 15–20 frames/sec 
Encode movies as a QuickTime movie using H.264 codec with Medium to Medium high quality. It will give you the best quality for size.
Wipe Firewire external hard drive clean before use
For PC, you’ll want a firewire card 
Snapshot view on an empty folder
Do the movie in takes instead of one long clip
Preferences: 
Fly to speed 0.18,  check on Show balloon when tour is paused.
Highlight tour, then hit play, and it will go through and pop balloons.
Resize Earth window to a standard size. Using big info windows? View Menu > View Size > 800 x 600 
Under View, turn off the compass feature
Fly path that you will take at a slow speed to allow Google Earth to load in all of the imagery to the cache
Clear out extra files in your My Places folders
Preferences: 3D view- make Labels big
Movie making with Google Earth: Recording videos for YouTube
Many users record a movie in Google Earth and distribute it via YouTube. If you’re not editing your video before uploading to YouTube, and don’t need to use a particular video codec, then the following compression types should work well for YouTube: HD 1920x1080 30p, h.264, HD1280x720 30p, h.264. Here’s how your settings should look in Movie Maker:
[image: https://lh6.googleusercontent.com/3coxKcCvy7-BJgYWC6VLRIyP5X_Ff6_v23oVFFhcxmUve77mgUutynXZeBo2pFfidONg7rakprG73rLPS8ob7wnd77HYcGfbNAEOAwS-XOj_mL_EPGK9oIcj6vTr0kraE2kKAA]
[image: https://lh4.googleusercontent.com/5t09TgYeMKn0DHXb6HbXGGbRmwVFyK32kLDKJ8kKtgtCRdIUdeYR-DnpQYgTJxXvKQFSERkfyWqpenn97sSpkcosptbFdSsjjULbK1Pd_t-qcgE8ZyIteMrnO7hZx5EveNWtTA]

My Personal Observations
GEP and GE share the same myplaces.klm file
Demo of Google Fusion Files
https://www.youtube.com/watch?v=5l7IyS3u4w8
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